[Pomoc] nece compile plugin :/
Results 1 to 24 of 24
  1. #1
    Senior Member Array
    Join Date
    Jun 2013
    Location
    Beograd
    Karma
    0

    Default nece compile plugin :/

    Prvi put mi se ovo desava. Ovo mi izbacuje kad compile lokalno

    Welcome to the AMX Mod X 1.8.1-300 Compiler.
    Copyright (c) 1997-2013 ITB CompuPhase, AMX Mod X Team

    D:\Counter-Strike WaRzOnE\cstrike\addons\amxmodx\scripting\include\c olorchat.inc(19) : error 021: symbol already defined: "TeamName"
    Error: Undefined symbol "client_print_color" on line 604
    Warning: Expression has no effect on line 604
    Error: Expected token: ";", but found ")" on line 604
    Error: Invalid expression, assumed zero on line 604
    Error: Too many error messages on one line on line 604

    Compilation aborted.
    5 Errors.
    Could not locate output file C:\Users\Aleksandar\Downloads\Untitled.amx (compile failed).



    Imam colorchat cak sam nasao na netu i chatcolor i to sam ubacio nije pomoglo..

  2. #2
    Moderator Array Rade.kgb's Avatar
    Join Date
    Jul 2012
    Location
    www.gamers.rs
    Karma
    6

    Default

    Pusti kod ovde da se proveri linija 604.

  3. #3
    Senior Member Array
    Join Date
    Mar 2010
    Location
    Serbia
    Age
    21
    Karma
    19

    Default

    Ima 2 colorchat.inc, zavisi koji tebi traži, stari ili novi.

  4. #4
    Senior Member Array
    Join Date
    Jun 2013
    Location
    Beograd
    Karma
    0

    Default

    Posalji mi oba, pa cu videti koji nemam i koji mi trazi
    Ubacio sam neki sto sam nasao 2017 ali nista ne vredi :/

    https://pastebin.com/tDsP4xtj
    Last edited by aleks.; 03-11-2017 at 12:49.

  5. #5
    Super Moderator Array klipica's Avatar
    Join Date
    Apr 2010
    Location
    lk-net.com
    Karma
    26

    Default

    client_print_color je deo AMXX 1.8.3.
    Code:
    #YoMama {
        width: 200%;
        overflow: visible;
    }

  6. #6
    Senior Member Array
    Join Date
    Jun 2013
    Location
    Beograd
    Karma
    0

    Default

    Quote Originally Posted by klipica View Post
    client_print_color je deo AMXX 1.8.3.
    Pa kako da compilujem sad ?

  7. #7
    Junior Member Array
    Join Date
    Dec 2015
    Location
    Macedonia
    Karma
    0

    Default

    izvoli amxx od taj sma kompaljirao sam ti ja https://www.sendspace.com/file/grx1g3
    Last edited by karpalak; 03-11-2017 at 15:27.

  8. #8
    Senior Member Array
    Join Date
    Jun 2013
    Location
    Beograd
    Karma
    0

    Default

    Hvala, ali mozes mi reci sta si uradio ? Sta je potrebno da uradim, posto do sada nisam imao problema kad sam compileplugin..

  9. #9
    Senior Member Array
    Join Date
    Mar 2010
    Location
    Serbia
    Age
    21
    Karma
    19

    Default

    Quote Originally Posted by aleks. View Post
    Posalji mi oba, pa cu videti koji nemam i koji mi trazi
    Ubacio sam neki sto sam nasao 2017 ali nista ne vredi :/

    https://pastebin.com/tDsP4xtj
    https://www.4shared.com/file/etZoRsznei/colorchat.html
    https://www.4shared.com/file/6wqd8zM...adiobican.html

  10. #10
    Junior Member Array
    Join Date
    Dec 2015
    Location
    Macedonia
    Karma
    0

    Default

    Quote Originally Posted by aleks. View Post
    Hvala, ali mozes mi reci sta si uradio ? Sta je potrebno da uradim, posto do sada nisam imao problema kad sam compileplugin..

    kompaljirao sam ga lokalno na 183 amx
    ubacio sam reapi include jer samo njega nisam imao

  11. #11
    Super Moderator Array klipica's Avatar
    Join Date
    Apr 2010
    Location
    lk-net.com
    Karma
    26

    Default

    Dzabe si radio to ako on nema 1.8.3 na serveru.
    Code:
    #YoMama {
        width: 200%;
        overflow: visible;
    }

  12. #12
    Senior Member Array
    Join Date
    Jun 2013
    Location
    Beograd
    Karma
    0

    Default

    Moram da imam obicnu verziju 1.8.3 ne mora ona Re ?

  13. #13
    Super Moderator Array klipica's Avatar
    Join Date
    Apr 2010
    Location
    lk-net.com
    Karma
    26

    Default

    ReAMXX ne treba uopste koristiti.
    Code:
    #YoMama {
        width: 200%;
        overflow: visible;
    }

  14. #14
    Senior Member Array
    Join Date
    Dec 2011
    Location
    Presevo
    Age
    22
    Karma
    7

    Default

    Quote Originally Posted by klipica View Post
    ReAMXX ne treba uopste koristiti.
    Moze li detaljnije o ovome,ako imas vremena?

  15. #15
    Super Moderator Array klipica's Avatar
    Join Date
    Apr 2010
    Location
    lk-net.com
    Karma
    26

    Default

    Quote Originally Posted by Cira '95 View Post
    Moze li detaljnije o ovome,ako imas vremena?
    AMXX 1.8.3 vec neko vreme ima podrsku za ReHLDS, zbog cega je ReAMXX i prvobitno bio napravljen.
    Drugo je sto je ReAMXX closed-source. Od open-source projekta su napravili closed-source, jako glupavo. To znaci da mogu da stave potpuno sta hoce unutra, niko nema uvid u kod.
    ReAMXX navodno ima i neke unapredjene stvari (optimizacija i tako dalje), ali pretpostavljam da je sto se tice apdejtova daleko iza oficijalne verzije, koja se i dan danas apdejtuje barem par puta mesecno, cesto i vise.
    Last edited by klipica; 04-11-2017 at 22:09.
    Code:
    #YoMama {
        width: 200%;
        overflow: visible;
    }

  16. #16
    Senior Member Array
    Join Date
    Jun 2013
    Location
    Beograd
    Karma
    0

    Default

    Kad se ubaci 1.8.3 verzija jako malo ima plugina koji rade na toj verziji..na primer ovaj radi na 1.8.3 a ne radi na 1.8.2.. Ipak je i dalje bolje koristiti 1.8.2 verziju..

  17. #17
    Senior Member Array
    Join Date
    Dec 2011
    Location
    Presevo
    Age
    22
    Karma
    7

    Default

    Hvala na odgovoru
    Jos nesto,izvinjavam se na spamu i offtopicu,al kad smo se vec uhvatili
    https://github.com/theAsmodai/metamod-r
    Da li je ovo ok,ima li nekog poboljsanja u odnosu na metamod 1.21 p 37 ili u odnosu na default-ni metamod ?

  18. #18
    Senior Member Array
    Join Date
    Jun 2013
    Location
    Beograd
    Karma
    0

    Default

    Kad sam ja testirao ovaj metamod samo radi na verziji 1.8.3..Na 1.8.2 nece da radi..Tako da koristim 1.21.p37

  19. #19
    Senior Member Array
    Join Date
    Dec 2011
    Location
    Presevo
    Age
    22
    Karma
    7

    Default

    Koristio ga i na serveru,al se za plugine ponasa kao reamxmodx...al za sve to se nadje adekvatna zamena u vidu plugina ili modula. Zanima me dal je stvarno optimizovaniji i vredi li cimati se oko njega

  20. #20
    Super Moderator Array klipica's Avatar
    Join Date
    Apr 2010
    Location
    lk-net.com
    Karma
    26

    Default

    Quote Originally Posted by aleks. View Post
    Kad se ubaci 1.8.3 verzija jako malo ima plugina koji rade na toj verziji..na primer ovaj radi na 1.8.3 a ne radi na 1.8.2.. Ipak je i dalje bolje koristiti 1.8.2 verziju..
    Ovo je netacno. AMXX je uvek potpuno backwards-compatible, sto znaci da bilo sta sto je napravljeno na prethodnim verzijama ce raditi i na najnovijoj verziji. Ako ne radi, to je bag i trebas prijaviti.
    Cak ne moras ni ponovo kompajlovati plugine za 1.8.3 ako su kompajlovani na prethodnoj verziji, kao 1.8.2.
    Code:
    #YoMama {
        width: 200%;
        overflow: visible;
    }

  21. #21
    Senior Member Array
    Join Date
    Dec 2011
    Location
    Presevo
    Age
    22
    Karma
    7

    Default

    Da,to je provereno tacno,ne rade sa 1.8.2 na reamx... i ne rade sa 1.8.2 u kombinaciji sa metamod r....zato i pitam za njega... generalno uz noviji metamod i rehlds serveri lepse rade,nema onog seckanja,a na neku foru,nije mi jasno kako,smanjuje i ping.

    edit: Lose sam se izrazio,Klipi je u pravu,sve sto radi na 1.8.2 radi i na 1.8.3 ukoliko ne petljas po metamodu.
    Last edited by Cira '95; 05-11-2017 at 00:00.

  22. #22
    Senior Member Array
    Join Date
    Jun 2013
    Location
    Beograd
    Karma
    0

    Default

    Oke hvala klipi
    Znaci onda slobodno 183 amxmod + metamod 1.21.p37 ( posto ovi noviji ne rade ) i plugini ce svi da sljakaju a bice bolje sto je napisao Cira

  23. #23
    Super Moderator Array klipica's Avatar
    Join Date
    Apr 2010
    Location
    lk-net.com
    Karma
    26

    Default

    Pre apdejtovanja kljucnih delova servera, kao sto su AMXX, Metamod i slicno, najbolje je prvo napraviti backup celog servera. Lako je pogresiti sa apdejtom, izbrisati ili overwrite stare fajlove i tako dalje, pogotovo sto AMXX 1.8.3 ima dosta novih fajlova u odnosu na 1.8.2.
    Code:
    #YoMama {
        width: 200%;
        overflow: visible;
    }

  24. #24
    Senior Member Array
    Join Date
    Jun 2013
    Location
    Beograd
    Karma
    0

    Default

    Ubacivao sam ja pre i 183 i ReAmxmod kad smo ono testirali i serveri radili normalno..samo da se pazi i jedno pojedno ubacivati..To za backup naravno..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •